import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[2-9]|\\d{2,})\\b";
final String string = "/page/0/\n"
+ "/page/1/\n"
+ "/page/10/\n"
+ "/page/11/\n"
+ "/page/15/\n"
+ "/page/2/\n"
+ "/page/20/\n"
+ "/page/21/\n"
+ "/page/201/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}