$re = '~\b(?:[2-9]|\d{2,})\b~m';
$str = '/page/0/
/page/1/
/page/10/
/page/11/
/page/15/
/page/2/
/page/20/
/page/21/
/page/201/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);