import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^java\\s+(?:\\S*-)?(?<version>\\d+(?:\\.\\d+){0,2}(?:[+_]\\d+)?)(?=(?:[-_](?!\\d))|$)(?:[-_.](?:ea|LTS|beta|snapshot|internal|b\\d+|\\d+[a-z]*))*$";
final String string = "java temurin-21.0.0+35.0.LTS";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}