const regex = /^java\s+(?:\S*-)?(?<version>\d+(?:\.\d+){0,2}(?:[+_]\d+)?)(?=(?:[-_](?!\d))|$)(?:[-_.](?:ea|LTS|beta|snapshot|internal|b\d+|\d+[a-z]*))*$/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^java\\s+(?:\\S*-)?(?<version>\\d+(?:\\.\\d+){0,2}(?:[+_]\\d+)?)(?=(?:[-_](?!\\d))|$)(?:[-_.](?:ea|LTS|beta|snapshot|internal|b\\d+|\\d+[a-z]*))*$', 'im')
const str = `java temurin-21.0.0+35.0.LTS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}