re = /^java\s+(?:\S*-)?(?<version>\d+(?:\.\d+){0,2}(?:[+_]\d+)?)(?=(?:[-_](?!\d))|$)(?:[-_.](?:ea|LTS|beta|snapshot|internal|b\d+|\d+[a-z]*))*$/im
str = 'java temurin-21.0.0+35.0.LTS'
# Print the match result
str.match(re) do |match|
puts match.to_s
end