// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\S+):\s*{\s*(((\S+):\s*"{{0,2}([^"{}]*)}{0,2}"\s*,?\s*)+)}"#).unwrap();
let string = "{
title1: {
x: \"abc\",
y: \"def\"
} ,
title2:{
x: \"{{abc}}\",
y: \"{{def}}\"
},
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}