#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?!(?:.\B)*(?:\B.)*\1)[dog]+)\b"
Local $sString = "dog" & @CRLF & _
"gos" & @CRLF & _
"aegihl;iaei" & @CRLF & _
"brog" & @CRLF & _
"go" & @CRLF & _
"god" & @CRLF & _
"dooooog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")