re = /\b((?!(?:.\B)*(?:\B.)*\1)[dog]+)\b/
str = 'dog
gos
aegihl;iaei
brog
go
god
dooooog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end