import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((25[0-5]|2[0-4]\\d|[01]?\\d{1,2})\\.){3}(25[0-5]|2[0-4]\\d|[01]?\\d{1,2})$";
final String string = "22.231.113.64\n"
+ "22.231.113.164\n"
+ "222.231.113.64\n"
+ "22.231.113.64\n"
+ "22.231.113.164\n"
+ "255.231.111.64\n"
+ "253.231.111.64\n"
+ "22.21.113.61\n"
+ "22.21.113.162\n"
+ "255.21.111.63\n"
+ "253.21.111.69\n"
+ "22.211.113.64\n"
+ "22.212.113.164\n"
+ "255.213.111.64\n"
+ "253.214.111.64\n\n"
+ "22.211.113.364\n"
+ "22.212.113.3164\n"
+ "255.213.111.464\n"
+ "253.214.111.564\n"
+ "not an ip address\n"
+ "not an ipv4 Address\n"
+ "Not an IPv5 Address";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}