import re
regex = re.compile(r"^((25[0-5]|2[0-4]\d|[01]?\d{1,2})\.){3}(25[0-5]|2[0-4]\d|[01]?\d{1,2})$", flags=re.MULTILINE)
test_str = ("22.231.113.64\n"
"22.231.113.164\n"
"222.231.113.64\n"
"22.231.113.64\n"
"22.231.113.164\n"
"255.231.111.64\n"
"253.231.111.64\n"
"22.21.113.61\n"
"22.21.113.162\n"
"255.21.111.63\n"
"253.21.111.69\n"
"22.211.113.64\n"
"22.212.113.164\n"
"255.213.111.64\n"
"253.214.111.64\n\n"
"22.211.113.364\n"
"22.212.113.3164\n"
"255.213.111.464\n"
"253.214.111.564\n"
"not an ip address\n"
"not an ipv4 Address\n"
"Not an IPv5 Address")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")