#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\+?[0-9]{2})?\(?[0-9]{2}\)?)?([0-9]?[0-9]{4}\-?[0-9]{4}))$"
Local $sString = "+55(91)3348-0276" & @CRLF & _
"559133480276" & @CRLF & _
"(91)3348-0276" & @CRLF & _
"9133480276" & @CRLF & _
"3348-0276" & @CRLF & _
"33480276" & @CRLF & _
"+55(91)98444-6776" & @CRLF & _
"5591984446776" & @CRLF & _
"(91)98444-6776" & @CRLF & _
"91984446776" & @CRLF & _
"98444-6776" & @CRLF & _
"984446776"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")