import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\+?[0-9]{2})?\\(?[0-9]{2}\\)?)?([0-9]?[0-9]{4}\\-?[0-9]{4}))$";
final String string = "+55(91)3348-0276\n"
+ "559133480276\n"
+ "(91)3348-0276\n"
+ "9133480276\n"
+ "3348-0276\n"
+ "33480276\n"
+ "+55(91)98444-6776\n"
+ "5591984446776\n"
+ "(91)98444-6776\n"
+ "91984446776\n"
+ "98444-6776\n"
+ "984446776";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}