import re
regex = re.compile(r"^(((\+?[0-9]{2})?\(?[0-9]{2}\)?)?([0-9]?[0-9]{4}\-?[0-9]{4}))$", flags=re.MULTILINE)
test_str = ("+55(91)3348-0276\n"
"559133480276\n"
"(91)3348-0276\n"
"9133480276\n"
"3348-0276\n"
"33480276\n"
"+55(91)98444-6776\n"
"5591984446776\n"
"(91)98444-6776\n"
"91984446776\n"
"98444-6776\n"
"984446776")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")