#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?<!\\|{)(?:\\\\)*\$({\$)?\w+(?(1)})"
Local $sString = "${$var1} bla ${$var2} bla ${$var2} foo bar ${$var3" & @CRLF & _
"\${$var2} bla \\\${$var2} bla $var1" & @CRLF & _
"\\${$var1} bla \\${$var2} bla \${$var2}" & @CRLF & _
"\\\{$var2} bla \\${$var2} bla \${$var2}" & @CRLF & _
"$var1 bla \$var1 bla \\$var1 bla \\\$var1" & @CRLF & _
"\$var1 bla \\$var1 bla \\\$var1" & @CRLF & _
"\\$var1 bla \\\$var1 bla \$var1 bla" & @CRLF & _
"\\\$var1 bla \\$var1 bla \\\$var1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")