$re = '/(?<!\\\\|{)(?:\\\\\\\\)*\$({\$)?\w+(?(1)})/u';
$str = '${$var1} bla ${$var2} bla ${$var2} foo bar ${$var3
\\${$var2} bla \\\\\\${$var2} bla $var1
\\\\${$var1} bla \\\\${$var2} bla \\${$var2}
\\\\\\{$var2} bla \\\\${$var2} bla \\${$var2}
$var1 bla \\$var1 bla \\\\$var1 bla \\\\\\$var1
\\$var1 bla \\\\$var1 bla \\\\\\$var1
\\\\$var1 bla \\\\\\$var1 bla \\$var1 bla
\\\\\\$var1 bla \\\\$var1 bla \\\\\\$var1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);