re = /(?<!\\|{)(?:\\\\)*\$({\$)?\w+(?(1)})/
str = '${$var1} bla ${$var2} bla ${$var2} foo bar ${$var3
\\${$var2} bla \\\\\\${$var2} bla $var1
\\\\${$var1} bla \\\\${$var2} bla \\${$var2}
\\\\\\{$var2} bla \\\\${$var2} bla \\${$var2}
$var1 bla \\$var1 bla \\\\$var1 bla \\\\\\$var1
\\$var1 bla \\\\$var1 bla \\\\\\$var1
\\\\$var1 bla \\\\\\$var1 bla \\$var1 bla
\\\\\\$var1 bla \\\\$var1 bla \\\\\\$var1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end