import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(<td style=\"width:50%\">((?!<\\/td>).)*?<\\/td>)";
final String string = "<div class=\"criteria\" style=\"padding-left:0;font-style:italic\"> You searched for: \n"
+ " <span title=\"A*\" >Individual: <span><b>A*</b></span></span>\n"
+ "</div>\n\n"
+ "</td>\n"
+ " </tr>\n"
+ "</table> <table cellpadding=\"5\" cellspacing=\"0\" border=\"0\" style=\"border-collapse: collapse; width: 100%\">\n\n"
+ " <tr class=\"ListItemColorNew\">\n"
+ " <td style=\"width:50%\">\n"
+ " <div class=\"gvListItemStyle\">\n"
+ " <span class=\"LargeText15\">JAMES BOND A'MONEYPENNY </span> (LIC# 1111111)\n"
+ " <div class=\"GrayTextShade\"><i>Alternate Names: BOND JAMES</i></div>\n\n"
+ " <div class=\"GrayTextShade\">\n"
+ " GREY TIDE LLC (LIC# 2222) \n"
+ " </div>\n\n"
+ " </div>\n"
+ " </td>\n"
+ " <td style=\"width: 25%; vertical-align: top\">\n"
+ " <div class=\"gvListItemStyle\">\n"
+ " <div><img alt=\"help\" src=\\'/Content/images/BrokerCheck/icon-blueCheck.png\\' style=\\'vertical-align:top;padding-right:5px\\' />Broker</div>\n"
+ " </div>\n"
+ " </td>\n"
+ " <td style=\"width:25%;text-align:right;vertical-align:top\">\n"
+ " <div class=\"gvListItemStyle\">\n"
+ "<a class=\"btn btn-primary\" href=\"/Individual/Summary/5820616\">Details »</a> </div>\n"
+ " </td>\n\n"
+ "</tr>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}