# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(<td style=\"width:50%\">((?!<\/td>).)*?<\/td>)"
test_str = ("<div class=\"criteria\" style=\"padding-left:0;font-style:italic\"> You searched for: \n"
" <span title=\"A*\" >Individual: <span><b>A*</b></span></span>\n"
"</div>\n\n"
"</td>\n"
" </tr>\n"
"</table> <table cellpadding=\"5\" cellspacing=\"0\" border=\"0\" style=\"border-collapse: collapse; width: 100%\">\n\n"
" <tr class=\"ListItemColorNew\">\n"
" <td style=\"width:50%\">\n"
" <div class=\"gvListItemStyle\">\n"
" <span class=\"LargeText15\">JAMES BOND A'MONEYPENNY </span> (LIC# 1111111)\n"
" <div class=\"GrayTextShade\"><i>Alternate Names: BOND JAMES</i></div>\n\n"
" <div class=\"GrayTextShade\">\n"
" GREY TIDE LLC (LIC# 2222) \n"
" </div>\n\n"
" </div>\n"
" </td>\n"
" <td style=\"width: 25%; vertical-align: top\">\n"
" <div class=\"gvListItemStyle\">\n"
" <div><img alt=\"help\" src=\\'/Content/images/BrokerCheck/icon-blueCheck.png\\' style=\\'vertical-align:top;padding-right:5px\\' />Broker</div>\n"
" </div>\n"
" </td>\n"
" <td style=\"width:25%;text-align:right;vertical-align:top\">\n"
" <div class=\"gvListItemStyle\">\n"
"<a class=\"btn btn-primary\" href=\"/Individual/Summary/5820616\">Details »</a> </div>\n"
" </td>\n\n"
"</tr>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.