using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
^(?>frac|\d+|(?<s>{)|(?<-s>}))+
(frac{\d+}{\d+})
(?=(?<-s>){3}(?(s)(?!)))";
string input = @"frac{frac{1}{2}}{frac{3}{frac{4}{frac{5}{6}}}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}