// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x)
^(?>frac|\d+|(?<s>{)|(?<-s>}))+
(frac{\d+}{\d+})
(?=(?<-s>){3}(?(s)(?!)))").unwrap();
let string = "frac{frac{1}{2}}{frac{3}{frac{4}{frac{5}{6}}}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}