import re
regex = re.compile((r"(?x)\n"
r"^(?>frac|\d+|(?<s>{)|(?<-s>}))+\n"
r"(frac{\d+}{\d+})\n"
r"(?=(?<-s>){3}(?(s)(?!)))"), flags=re.MULTILINE)
test_str = "frac{frac{1}{2}}{frac{3}{frac{4}{frac{5}{6}}}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")