package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w-_\d]*[@].*\.\w{2,}`)
var str = `hzkov_3000@yandex.ru`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}