const regex = /[\w-_\d]*[@].*\.\w{2,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w-_\\d]*[@].*\\.\\w{2,}', '')
const str = `hzkov_3000@yandex.ru`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}