$re = '/[\w-_\d]*[@].*\.\w{2,}/';
$str = 'hzkov_3000@yandex.ru';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);