package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^x]|\b)(x{3}|x{5})(?:[^x]|\b)`)
var str = `xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}