const regex = /(?:[^x]|\b)(x{3}|x{5})(?:[^x]|\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^x]|\\b)(x{3}|x{5})(?:[^x]|\\b)', 'gm')
const str = `xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}