import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^x]|\\b)(x{3}|x{5})(?:[^x]|\\b)";
final String string = "xxxxx\n"
+ "xxxx xxxxx xxx\n"
+ "xx xxxxx xx xxx\n"
+ "xxxxxx\n"
+ "xxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}