# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(p|li)\b[^<>]*>[^<>\n]*)\b(Cat|Dog|Fish)\b([^<>\n]*<\\/\2>)/$1lol$4/gm;t' <<< "(1) <p> Cat test dfdsf</p>
(2) <p> Cat.</p>
(3) <p>Cat.</p>
(4) <p class=\"test\">Cat</p>
(5) <li>Cat</li>
(6) <p>Catfgdggh</p>
(7) <div>Cat</div>"