use strict;
my $str = '(1) <p> Cat test dfdsf</p>
(2) <p> Cat.</p>
(3) <p>Cat.</p>
(4) <p class="test">Cat</p>
(5) <li>Cat</li>
(6) <p>Catfgdggh</p>
(7) <div>Cat</div>';
my $regex = qr/(<(p|li)\b[^<>]*>[^<>\n]*)\b(Cat|Dog|Fish)\b([^<>\n]*<\/\2>)/mp;
my $subst = '$1lol$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";