$re = '/(<(p|li)\b[^<>]*>[^<>\n]*)\b(Cat|Dog|Fish)\b([^<>\n]*<\/\2>)/m';
$str = '(1) <p> Cat test dfdsf</p>
(2) <p> Cat.</p>
(3) <p>Cat.</p>
(4) <p class="test">Cat</p>
(5) <li>Cat</li>
(6) <p>Catfgdggh</p>
(7) <div>Cat</div>';
$subst = "$1lol$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;