using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"France\s+\d+-\d+\s+Germany";
string input = @"Current score is France 0-0 Germany today.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}