$re = '/France\s+\d+-\d+\s+Germany/';
$str = 'Current score is France 0-0 Germany today.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);