re = /France\s+\d+-\d+\s+Germany/
str = 'Current score is France 0-0 Germany today.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end