use strict;
my $str = '(11-6 11-4 11-5 11-5 11-5)';
my $regex = qr/\((\d+-\d+)\s*(\d+-\d+\s*){2,4}\)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";