import Foundation
let pattern = #"\((\d+-\d+)\s*(\d+-\d+\s*){2,4}\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"(11-6 11-4 11-5 11-5 11-5)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)