re = /^([acgtnACGTN]+)$|^<(INS|DEL|DUP|INV|CNV|DUP:TANDEM|INS:NOVEL|INS:ME|DEL:ME)>$/m
str = '<DEL:ME>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end