// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([acgtnACGTN]+)$|^<(INS|DEL|DUP|INV|CNV|DUP:TANDEM|INS:NOVEL|INS:ME|DEL:ME)>$").unwrap();
let string = "<DEL:ME>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}