using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{(?<inner>.*?)}}|(?<outer>[^{}]*(?:{(?!{)[^{}]*|}(?!})[^{}]*)*)";
string input = @"Fo{rest{{Go{l}d}}Beach{{Monay}}Grass{{Diamond}}S{ea";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}