$re = '/{{(?<inner>.*?)}}|(?<outer>[^{}]*(?:{(?!{)[^{}]*|}(?!})[^{}]*)*)/';
$str = 'Fo{rest{{Go{l}d}}Beach{{Monay}}Grass{{Diamond}}S{ea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);