re = /{{(?<inner>.*?)}}|(?<outer>[^{}]*(?:{(?!{)[^{}]*|}(?!})[^{}]*)*)/
str = 'Fo{rest{{Go{l}d}}Beach{{Monay}}Grass{{Diamond}}S{ea'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end