#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^a-z]+|[^A-Z]+)$).*$"
Local $sString = "abc" & @CRLF & _
"ABC" & @CRLF & _
"123" & @CRLF & _
"abc123" & @CRLF & _
"ABC123&^" & @CRLF & _
"" & @CRLF & _
"AbC" & @CRLF & _
"A12b" & @CRLF & _
"AB^%12c" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")