$re = '/^(?=(?:[^a-z]+|[^A-Z]+)$).*$/m';
$str = 'abc
ABC
123
abc123
ABC123&^
AbC
A12b
AB^%12c
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);