using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^a-z]+|[^A-Z]+)$).*$";
string input = @"abc
ABC
123
abc123
ABC123&^
AbC
A12b
AB^%12c
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}