using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(c+d))";
string substitution = @"";
string input = @"cccd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}