const regex = /(?=(c+d))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(c+d))', 'g')
const str = `cccd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);