use strict;
my $str = 'cccd';
my $regex = qr/(?=(c+d))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";