const regex = new RegExp('<\\s*meta\\s
# using lookahead to capture type to $1
(?=[^>]*?
\\b(?:name|property|itemprop|http-equiv)\\s*=\\s*
(?|"\\s*([^"]*?)\\s*"|\\'\\s*([^\\']*?)\\s*\\'|
([^"\\'>]*?)(?=\\s*/?\\s*>|\\s\\w+\\s*=))
)
# capture the content to $2
[^>]*?\\bcontent\\s*=\\s*
(?|"\\s*([^"]*?)\\s*"|\\'\\s*([^\\']*?)\\s*\\'|
([^"\\'>]*?)(?=\\s*/?\\s*>|\\s\\w+\\s*=))
[^>]*>
', 'gi')
const str = `<meta content = foo name = bar />
<meta name= bar sdf content= foo >
<meta content="name" name="author">
<meta name ="keywords" content = " php documentation ">
<meta name= "DESCRIPTION" content=" a php manual ">
<meta name="geo.position" content="49.33;-86.59 ">
<meta content=' 49.33;-86.59' name = geo.position >
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}