// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ix)<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|itemprop|http-equiv)\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
[^>]*>
"#).unwrap();
let string = "<meta content = foo name = bar />
<meta name= bar sdf content= foo >
<meta content=\"name\" name=\"author\">
<meta name =\"keywords\" content = \" php documentation \">
<meta name= \"DESCRIPTION\" content=\" a php manual \">
<meta name=\"geo.position\" content=\"49.33;-86.59 \">
<meta content=' 49.33;-86.59' name = geo.position >
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}