re = /<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|itemprop|http-equiv)\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*\/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*\/?\s*>|\s\w+\s*=))
[^>]*>
/ix
str = '<meta content = foo name = bar />
<meta name= bar sdf content= foo >
<meta content="name" name="author">
<meta name ="keywords" content = " php documentation ">
<meta name= "DESCRIPTION" content=" a php manual ">
<meta name="geo.position" content="49.33;-86.59 ">
<meta content=\' 49.33;-86.59\' name = geo.position >
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end