import re
regex = re.compile(r"^\d+(?:\.\d+)*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("25.23.25\n"
"25.2323.5656.5656344444444444444444444444444444444444444444444444444444444444444444444444444444444444344444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444\n"
"25")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)